您的位置:首页 > 编程语言

POJ-3468A Simple Problem with Integers,线段数区间更新查询,代码打了无数次还是会出错~~

2016-04-25 21:49 281 查看
A Simple Problem with Integers

Time Limit: 5000MSMemory Limit: 131072K














Case Time Limit: 2000MS
Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is
to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output
4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly--2007.11.25, Yang Yi

这个题无非就是更新某个区间然后查询,思路甚至比其它的线段树要简单,但写起来却每次都出错;

思路很简单,如果每次更新都遍历到叶节点,毫无疑问会超时,既然是区间更新,我们可以先将要增加的值存在包含本区间的父亲区间里,下次往子节点操作时再进行类似的操作,也就是加上父亲节点储存的要增加的值,看代码+注释:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int  N=100000+10;
int n,m,s
;
struct node
{
int l,r;
long long n,add;//注意数据范围;
} a[N<<2];
void build(int l,int r,int k)//构建就没啥好讲的;
{
a[k].l=l,a[k].r=r,a[k].add=0;
if(l==r)
{
a[k].n=s[l];
return ;
}
int mid=(l+r)/2;
build(l,mid,2*k);
build(mid+1,r,2*k+1);
a[k].n=a[k*2].n+a[k*2+1].n;
}
void update(int l,int r,int c,int k)
{
if(l<=a[k].l&&a[k].r<=r)
{
a[k].n+=(a[k].r-a[k].l+1)*c;//满足条件的话,这个区间每个元素都要加上c;
a[k].add+=c;将增加的值储存起来,下次更新操作时再往子节点更新;
return ;
}
if(a[k].add)//如果父亲节点增加值还在,那么子节点也要进行更新操作;
{
a[k*2].add+=a[k].add;
a[k*2+1].add+=a[k].add;
a[k*2].n+=(a[k*2].r-a[k*2].l+1)*a[k].add;
a[k*2+1].n+=(a[k*2+1].r-a[k*2+1].l+1)*a[k].add;
a[k].add=0;
}
int mid=(a[k].l+a[k].r)/2;
if(l<=mid) update(l,r,c,2*k);
if(r>mid) update(l,r,c,2*k+1);
a[k].n=a[k*2].n+a[k*2+1].n;回溯;
}
long long query(int l,int r,int k)
{
if(a[k].l==l&&a[k].r==r)
return a[k].n;
if(a[k].add)
{
a[k*2].add+=a[k].add;
a[k*2+1].add+=a[k].add;
a[k*2].n+=(a[k*2].r-a[k*2].l+1)*a[k].add;
a[k*2+1].n+=(a[k*2+1].r-a[k*2+1].l+1)*a[k].add;
a[k].add=0;
}
int mid=(a[k].l+a[k].r)/2;
if(l>mid) return query(l,r,2*k+1);
if(r<=mid) return query(l,r,2*k);
return query(l,mid,2*k)+query(mid+1,r,2*k+1);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(a,0,sizeof(a));
for(int i=1; i<=n; i++)
scanf("%d",&s[i]);
build(1,n,1);
while(m--)
{
int a,b,c;
getchar();
char o=getchar();
if(o=='Q')
{
scanf("%d%d",&a,&b);
printf("%I64d\n",query(a,b,1));
}
else
{
scanf("%d%d%d",&a,&b,&c);
update(a,b,c,1);
}
}
}
return 0;
}


其实写出来发现也没什么改变,只不过关键在于更新和查询的时候往子节点所进行的操作;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: