您的位置:首页 > 其它

HDOJ1175(BFS)

2016-04-25 19:46 281 查看
Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。

玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。

注意:询问之间无先后关系,都是针对当前状态的!

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0


Sample Output

YES
NO
NO
NO
NO
YES


分析:点可以重复走,但在同一点沿同一方向走过最多两次。

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,m;
int next1[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int ch[1005][1005];
struct nu
{
int x,y,from,sum;
};
int num [1005][1005][4];

int bfs(int ax,int ay,int ex,int ey)
{
if(ch[ax][ay]!=ch[ex][ey]||ch[ax][ay]==0||ch[ex][ey]==0)
return 0;
queue<nu>q;nu s;
s.x=ax;s.y=ay;
while(!q.empty())
q.pop();
q.push(s);

while(!q.empty())
{
nu fx=q.front();
if(fx.x==ex&&fx.y==ey)
return 1;
for(int i=0;i<=3;i++)
{
nu fy;
fy.x=fx.x+next1[i][0];
fy.y=fx.y+next1[i][1];
if(fy.x>=0&&fy.x<n&&fy.y>=0&&fy.y<m&&(ch[fy.x][fy.y]==0||(fy.x==ex&&fy.y==ey))&&num[fy.x][fy.y][i]<2)
{

if(fx.x==ax&&fx.y==ay)
{
fy.from=i;
fy.sum=0;
q.push(fy);
num[fy.x][fy.y][i]++;
}
else
{
if(i==fx.from)
{
fy.from=i;
fy.sum=fx.sum;
q.push(fy);
num[fy.x][fy.y][i]++;
}

if(i!=fx.from&&fx.sum<2)
{
fy.from=i;
fy.sum=fx.sum+1;
q.push(fy);
num[fy.x][fy.y][i]++;
}
}
}
}
q.pop();
}
return 0;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF&&n&&m)
{
for (int i=0;i<n;i++)
for(int j=0;j<m;j++)
scanf("%d",&ch[i][j]);
int q1,x1,x2,y1,y2;
scanf("%d",&q1);
while(q1--)
{
memset(num,0,sizeof(num));
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
if(bfs(x1-1,y1-1,x2-1,y2-1))
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: