您的位置:首页 > 其它

UVa 1395 slim span

2016-04-25 18:39 369 查看
问题描述:

The graph G is an ordered pair (V, E) , where V is a set of vertices {v1, v2,…, vn} and E is a set of undirected edges {e1, e2,…, em} . Each edge e ∈ \in E has its weight w(e) .

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n - 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n - 1 edges of T .



For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5} . The weights of the edges are w(e1) = 3 , w(e2) = 5 , w(e3) = 6 , w(e4) = 6 , w(e5) = 7 as shown in Figure 5(b).

=6in



There are several spanning trees for G . Four of them are depicted in Figure 6(a)∼(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb , Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m

a1 b1 w1

⋮ \vdots

am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space.

n is the number of the vertices and m the number of the edges. You can assume 2≤ \len≤ \le100 and 0≤ \lem≤ \len(n - 1)/2 . ak and bk (k = 1,…, m) are positive integers less than or equal to n , which represent the two vertices vak and vbk connected by the k -th edge ek . wk is a positive integer less than or equal to 10000, which indicates the weight of ek . You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, `-1’ should be printed. An output should not contain extra characters.

Sample Input

4 5

1 2 3

1 3 5

1 4 6

2 4 6

3 4 7

4 6

1 2 10

1 3 100

1 4 90

2 3 20

2 4 80

3 4 40

2 1

1 2 1

3 0

3 1

1 2 1

3 3

1 2 2

2 3 5

1 3 6

5 10

1 2 110

1 3 120

1 4 130

1 5 120

2 3 110

2 4 120

2 5 130

3 4 120

3 5 110

4 5 120

5 10

1 2 9384

1 3 887

1 4 2778

1 5 6916

2 3 7794

2 4 8336

2 5 5387

3 4 493

3 5 6650

4 5 1422

5 8

1 2 1

2 3 100

3 4 100

4 5 100

1 5 50

2 5 50

3 5 50

4 1 150

0 0

Sample Output

1

20

0

-1

-1

1

0

1686

50

分析:

题意:给出一个n(你<=100)节点的图,求苗条度(最大边减最小边的值)尽量小的生成树。

使用kruskal算法。首先把边值从小到大排序,对于一个连续的边集区间[L,R],如果这些边使得n个点联通,那么他们的苗条度为w[R]-W[L],R为组成最小生成树的最后一条边,L为区间的第一条边(区间的第一条边即最小边一定会被选择,刚开始时不可能会有成环的情况)。

从小到大枚举L,对于每个L,从小到大枚举R,取了n-1条边就停止。

AC代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;

const int INF=100000000;
const int maxn=105;
int n;

int pa[maxn];
int findset(int x){return pa[x]==x?x:pa[x]=findset(pa[x]);}

struct Edge
{
int u;
int v;
int w;
Edge(int a,int b,int c):u(a),v(b),w(c){}
bool operator < (const Edge& r)const
{
return w<r.w;
}
};

vector<Edge> ve;

int solve()
{
int m=ve.size();
sort(ve.begin(),ve.end());
int ans=INF;
for(int L=0;L<m;L++)
{
for(int i=1;i<=n;i++) pa[i]=i;
int cnt=n;
for(int R=L;R<m;R++)
{//第一个ve[L]必定被选中!!
int x=findset(ve[R].u),y=findset(ve[R].v);
if(x!=y)
{
pa[x]=y;
if(--cnt==1)
{
ans=min(ans,ve[R].w-ve[L].w);
break;
}
}
}
}
if(ans==INF) ans=-1;
return ans;
}

int main()
{
int m,u,v,w;
while(scanf("%d%d",&n,&m)!=EOF)
{
ve.clear();//初始化清空!!
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&w);
ve.push_back(Edge(u,v,w));
}
printf("%d\n",solve());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: