您的位置:首页 > 其它

练习2- Strange fuction

2016-04-24 21:32 169 查看

题目:

[align=left]Problem Description[/align]
Now, here is a fuction:<br>  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)<br>Can you find the minimum value when x is between 0 and 100.
 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

[align=left]Output[/align]
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

[align=left]Sample Input[/align]

2<br>100<br>200

 

[align=left]Sample Output[/align]

-74.4291<br>-178.8534

 

[align=left]Author[/align]
Redow

题意:

           解方程;

思路:

           解方程,对方程进行求导,然后跟第一题做法一样,求出x;

代码:

          
# include <iostream>
# include <cmath>
# include <iomanip>

using namespace std;

double f (double x, double y)
{
return 6 * pow(x, 7) + 8 * pow(x, 6) + 7 * pow(x, 3)+ 5 * x * x - y * x;
}
double ff (double x)
{
return 42 * pow(x, 6) + 48 * pow(x, 5) + 21 * x * x + 10 * x ;

}
int main()
{
int n;
cin >> n;
while (n--)
{
double min = 0, max = 100, x;
int y;
cin >> y;
while (1)
{
x = (min + max) / 2;
if (fabs(ff(x) - y) < 1e-4)
{
cout << fixed << setprecision(4) <<  f (x, y) << endl;
break;
}
else if (ff(x) > y)
{
max = x;

}
else
{
min = x;
}
}

}
return 0;
}

//42 * pow(x, 6) + 48 * pow(x, 5) + 10 * x - y;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: