您的位置:首页 > 移动开发

ZOJ 3936 Apples and Ideas

2016-04-23 23:05 253 查看
Apples and Ideas
Time Limit: 2 Seconds      Memory Limit: 65536 KB
"If you have an apple and I have an apple and we exchange these apples then you and I will still each have one apple. But if you have an idea and I have an idea and we exchange these
ideas, then each of us will have two ideas." - George Bernard Shaw
Now Alice has A apples and B ideas, while Bob has C apples and D ideas, what will they have if they exchange all things?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The only line contains four integers A, B, C, D (0 <= A, B, C, D <= 100) - as the problem described.

Output

For each test case, output two lines. First line contains two integers, indicating the number of Alice's apples and ideas; second line contains two integers, indicating the number of
Bob's apples and ideas.

Sample Input

4
0 0 5 30
20 25 20 0
20 25 20 15
20 25 25 30

Sample Output

5 30
0 30
20 25
20 25
20 40
20 40
25 55
20 55

Author: DAI, Longao
Source: The 13th Zhejiang Provincial Collegiate Programming Contest

省赛第一道,大水题,两分钟一A

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 4;
int T, a, b, c, d;

int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d%d%d%d", &a, &b, &c, &d);
printf("%d %d\n%d %d\n", c, b + d, a, b + d);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  zoj