您的位置:首页 > 其它

ACM2-1001

2016-04-23 17:26 393 查看
Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

Sample Input

2
100
-4

 

Sample Output

1.6152
No solution!

 

函数为递增函数,使用2分法解题比较简单,直接套用。

//8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y

#include<stdio.h>
#include<math.h>
double fun(double x)
{
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}
int main()
{
int t;
double y,mid;
cin>>t;
while(t--)
{
cin>>y;
if(fun(1)>y||fun(100)<y)
{
cout<<"No solution!"<<endl;
}
else
{
double l=0,r=100;
while(r-l>1e-9)
{
mid=(r+l)/2;
if(fun(mid)>y) r=mid;
else l=mid;
}
cout<<mid;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm