您的位置:首页 > 其它

PAT (Advanced Level) Practise 1105. Spiral Matrix (25) 蛇形填数

2016-04-23 13:55 435 查看


1105. Spiral Matrix (25)

时间限制

150 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The
matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is
the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The
numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76


基本上就是nyoj上一道蛇形填数的原题。。。连N的范围都没给。。。不过从时间限制150ms推测肯定不大,可以用数组存

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int maxn = 10000 + 10;
int a[maxn];

//按题目要求找m和n
void f(int N, int& m, int& n) {
for (int i = 1; i <= N; i++) {
if (N % i == 0) {
if (i < N / i) continue;
if (i - N / i < m - n) {
m = i;
n = N / i;
}
}
}
}

bool cmp(int x, int y) {
return x > y;
}

int MAP[1005][1005];

int main()
{
int N, m, n;
scanf("%d", &N);
for (int i = 1; i <= N; i++) {
scanf("%d", &a[i]);
}
m = 11111, n = 0;
f(N, m, n);

sort(a + 1, a + 1 + N, cmp);
//m row n col
memset(MAP, -1, sizeof(MAP));
int i = 1, j = 1, cnt = 1;
while (cnt <= N) {
//right
while (MAP[i][j] == -1 && j <= n) {
MAP[i][j] = a[cnt++];
j++;
}
j -= 1; //注意往回走一步,不然越界了
i += 1; //注意往下走一步,不然重复了

//down
while (MAP[i][j] == -1 && i <= m) {
MAP[i][j] = a[cnt++];
i++;
}
i -= 1;
j -= 1;

//left
while (MAP[i][j] == -1 && j >= 1) {
MAP[i][j] = a[cnt++];
j--;
}
j += 1;
i -= 1;

//up
while (MAP[i][j] == -1 && i >= 1) {
MAP[i][j] = a[cnt++];
i--;
}
i += 1;
j += 1;
}

for (int i = 1; i <= m; i++) {
for (int j = 1; j <= n; j++) {
if (j == 1)
printf("%d", MAP[i][j]);
else
printf(" %d", MAP[i][j]);
}
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: