您的位置:首页 > 其它

UVA - 401 Palindromes

2016-04-23 13:24 344 查看
Palindromes

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right
as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is
a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA"is a mirrored palindrome because if the string is read backwards, the string is the same as the
original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

Of course,"A","T", "O",
and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
BNZ5
COO11
DP2S
E3Q3E
FR4
GS25Z
HHTT6
IIUU7
JLVV88
KWW9
LJXX
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA


Sample Output

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.


Hint

use the C++'s class of string will be convenient, but not a must

分析:

这题是Rujia Liu推荐的第一个字符串题。

题意很容易看懂,就是给出字符串,判断其是否是回文或镜面对称回文。输出有4种情况,给出的表格做了很清楚的说明。

思路:写两个函数,is_palindrome()判断是否是回文串,is_mirrored()判断是否是镜像对称串。

代码:

#include <stdio.h>

#include <string.h>

#define MAXN 1024

char const *ch = "AEHIJLMOSTUVWXYZ12358";

char const *re = "A3HILJMO2TUVWXY51SEZ8";

int is_palindrome(char *str)

{

int i,len = strlen(str);

for(i=0; i<len/2; i++)

{

if(str[i] != str[len-i-1])

return 0;

}

return 1;

}

int is_mirrored(char *str)

{

int table_len = strlen(ch);

int i,j,len = strlen(str);

if(len == 1)

{

for(j=0; j<table_len; j++)

{

if(ch[j] == str[0])

break;

}

if(j == 21 || re[j] != str[0])

return 0;

}

else if(len > 1)

for(i=0; i<len/2; i++)

{

for(j=0; j<table_len; j++)

{

if(ch[j] == str[i])

break;

}

if(j == 21 || re[j] != str[len-i-1])

return 0;

}

return 1;

}

int main()

{

//freopen("C:\\in.txt","r",stdin);

char str[MAXN];

while(scanf("%s",str) != EOF)

{

if(is_palindrome(str))

{

if(is_mirrored(str))

printf("%s -- is a mirrored palindrome.\n\n",str);

else

printf("%s -- is a regular palindrome.\n\n",str);

}

else

{

if(is_mirrored(str))

printf("%s -- is a mirrored string.\n\n",str);

else

printf("%s -- is not a palindrome.\n\n",str);

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: