您的位置:首页 > 其它

ZOJ 2965 Accurately Say "CocaCola"!

2016-04-23 11:11 344 查看
Accurately Say "CocaCola"!

Time Limit: 2 Seconds Memory Limit: 65536 KB

In a party held by CocaCola company, several students stand in a circle and play a game.
One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts
a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.
For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth
one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.
During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?
For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation
happen.
Input
Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be
followed by Tconsecutive test cases.
There is only one line for each case. The line contains only one integer p (1 <= p <= 99).
Output
Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p"CocaCola"s
stands for.
Sample Input

2
2
3


Sample Output

27
70

注意:280也可以被7整除

#include <cstdio>
using namespace std;

int t;
int n;
int main()
{
scanf("%d", &t);
while (t--){
scanf("%d", &n);
if (n == 1)
printf("7\n");
else if (n  == 2)
printf("27\n");
else if (n >= 3 && n <= 10)
printf("70\n");
else if (n == 11)
printf("270\n");   //注意
else
printf("700\n");
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: