您的位置:首页 > 其它

poj 2488 A Knight's Journey ——dfs

2016-04-23 08:16 302 查看

题目:

E - A Knight's Journey

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit Status

Description

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world
of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a
single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q
letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1.
Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed
by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name
consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input

3

1 1

2 3

4 3

Sample Output

Scenario #1:

A1

Scenario #2:

impossible

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

题目大意:

给一个最大26*26的图,只能按照国际象棋皇后的走法,求从(1,1)出发能否走完全图的每一个点.并打印可能路径

题目思路:

因为要求打印结果路径,所以需要用ans【】数组保留结果,一旦到达成立,就可以打印结果。搜索时按照字典序来搜索,dfs。成立的结果是长度为m*n

程序:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cctype>
using namespace std;
int fang[8][2]= { -2,-1, -2,1, -1,-2, -1,2, 1,-2, 1,2, 2,-1, 2,1};
bool v[30][30];
struct la
{
int x,y;
}a[900];
int dfs(int m,int n,int xx,int yy,int bu)
{
//cout<<xx<<yy<<bu<<endl;
a[bu].x=xx,a[bu].y=yy;
if(bu==m*n)
return 1;
for(int i=0; i<8; i++)
{
int x=xx+fang[i][0];
int y=yy+fang[i][1];
if(x>0&&y>0&&x<=m&&y<=n)
if(!v[x][y])
{
v[x][y]=1;
if(dfs(m,n,x,y,bu+1))
return 1;
v[x][y]=0;
}
}
return 0;
}
int main()
{
int ci,m,n,t=1;
scanf("%d",&ci);
while(ci--)
{
memset(v,0,sizeof(v));
scanf("%d%d",&n,&m);
v[1][1]=1;
printf("Scenario #%d:\n",t++);
if(dfs(m,n,1,1,1))
{
for(int i=1;i<=m*n;i++)
printf("%c%d",a[i].x+'A'-1,a[i].y);
printf("\n");
}
else
printf("impossible\n");
if(ci)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: