您的位置:首页 > 其它

UVA - 10055 Hashmat the Brave Warrior

2016-04-22 22:38 316 查看
Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to

fight against his opponents. Before Fighting he just calculates one thing, the difference between his

soldier number and the opponent’s soldier number. From this difference he decides whether to fight or

not. Hashmat’s soldier number is never greater than his opponent.

Input

The input contains two numbers in every line. These two numbers in each line denotes the number

soldiers in Hashmat’s army and his opponent’s army or vice versa. The input numbers are not greater

than 232. Input is terminated by ‘End of File’.

Output

For each line of input, print the difference of number of soldiers between Hashmat’s army and his

opponent’s army. Each output should be in seperate line.

Sample Input

10 12

10 14

100 200

Sample Output

2

4

100

分析:

题目大意:求敌我双方的人数差。

水。

ac代码:

#include <iostream>

using namespace std;

int main()

{

long a,b;

while(cin>>a>>b)

{

cout<<(a<b ? b-a :a-b )<<endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: