您的位置:首页 > 其它

1014-A strange lift

2016-04-22 22:15 423 查看
[align=left]Problem Description[/align]
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP"
, you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than
1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't
do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?<br>
 

[align=left]Input[/align]
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0
indicate the end of the input.
 

[align=left]Output[/align]
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

[align=left]Sample Input[/align]

5 1 5<br>3 3 1 2 5<br>0

 

[align=left]Sample Output[/align]

3
简单题意:   有一个奇怪的电梯,在每一层只能上升或下降一个特定的数字,中间不会停止。现在要求写出一个程序,求出可不可以到达指定的楼层,可以的话输出次数,否则return -1;解题思路形成过程:  拿到题目,第一眼的感觉就是,这是一个需要广度优先搜索来实现的题目。而本题有正是如此。写出BFS函数,一切就迎刃而解了
感想: 跟上一道1013的很类似,都是用的广度搜索。

#include <iostream>#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
struct node
{
 int pos,t;
 friend bool operator<(node a,node b)
 {
  return a.t>b.t;
 }
};
priority_queue<node>s;
int lift[205],vis[205],n;
int dijkstra(int st,int ed)
{
 node temp,temp1;
 int flag=0;
 temp.pos=st,temp.t=0;
 s.push(temp);
 while(!s.empty())
 {
  temp1=temp=s.top(),s.pop();
  vis[temp.pos]=1;
  if(temp.pos==ed)
  {
   flag=1;
   break;
  }
  temp.pos=temp1.pos-lift[temp1.pos];//
  temp.t=temp1.t+1;
  if(temp.pos>=1&&temp.pos<=n&&!vis[temp.pos])
  s.push(temp);
  temp.pos=temp1.pos+lift[temp1.pos];
  temp.t=temp1.t+1;
  if(temp.pos>=1&&temp.pos<=n&&!vis[temp.pos])
  s.push(temp);
 }
 if(flag)
 return temp.t;
 else
 return -1;
}
int main()
{
 int st,ed;
 while(scanf("%d",&n)!=EOF)
 {
  if(n==0)
  break;
  scanf("%d %d",&st,&ed);
  for(int i=1;i<=n;i++)
  scanf("%d",&lift[i]);
  memset(vis,0,sizeof(vis));
  while(!s.empty())
  s.pop();
  printf("%d\n",dijkstra(st,ed));
 }
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: