您的位置:首页 > 其它

HDU 1102 Constructing Roads(Kruskal)

2016-04-22 20:03 344 查看


Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19432 Accepted Submission(s): 7404



Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2


Sample Output

179
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
int n;
int a;
int q;
int b,c;
struct Node
{
int x;
int y;
int w;
}edge[105*105];
int father[105];
int cmp(Node a,Node b)
{
return a.w<b.w;
}
int find(int x)
{
if(x!=father[x])
x=find(father[x]);
return x;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++)
father[i]=i;
int cot=0;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
scanf("%d",&a);
if(i==j)
continue;
edge[cot].x=i;
edge[cot].y=j;
edge[cot++].w=a;
}
scanf("%d",&q);
for(int i=1;i<=q;i++)
{
scanf("%d%d",&b,&c);
b=find(b);
c=find(c);
father[b]=c;
}
sort(edge,edge+cot,cmp);
int ans=0;
for(int i=0;i<cot;i++)
{
int xx=edge[i].x;
int yy=edge[i].y;
xx=find(xx);
yy=find(yy);
if(xx!=yy)
{
ans+=edge[i].w;
father[xx]=yy;
}
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: