您的位置:首页 > 其它

NYOJ 284 坦克大战

2016-04-22 10:11 369 查看


坦克大战

时间限制:1000 ms | 内存限制:65535 KB
难度:3

描述
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).



Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you
can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear
(i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

输入The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T'
(target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

样例输入
3 4
YBEB
EERE
SSTE
0 0


样例输出
8


来源POJ
上传者
sadsad

题目描述:
输入初始的二维数组表示当前的状态,Y为你的位置,T为目标位置,输出到目标位置最少的步数,如果不能到达输出-1。
要求:你可以走上下左右四个位置,但是有河流或刚墙的位置的不能走,如果前面有砖墙需要打掉砖墙之后再走,所以此时需要两步到达砖墙的位置。
思想:优先队列/bfs
代码:

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;
#define  max 305
char map[max][max];    // 输入的二维数组
int n,m;
bool vist[max][max];  //标记是否已经访问过
int d[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
struct node
{
int x,y,c;
friend bool operator <(const node &s1,const node &s2)
{
return s1.c>s2.c;  //最小值优先
}
};
node s,e;
int bfs()
{
priority_queue < node > q;
memset(vist,0,sizeof(vist));
node now,t;
s.c=0;
q.push(s);
vist[s.x][s.y]=1;
while (!q.empty())
{
now=q.top();
q.pop();
if (now.x==e.x&&now.y==e.y)
{
return now.c;
}
for (int i=0;i<4;i++)
{
t.x=now.x+d[i][0];
t.y=now.y+d[i][1];
if (t.x>=0&&t.x<n&&t.y>=0&&t.y<m&&!vist[t.x][t.y])  //判断是否合法并且没有被访问
{
vist[t.x][t.y]=1;    //被访问标记为1
if (map[t.x][t.y]=='B')
{
t.c=now.c+2;
q.push(t);
}
else
if (map[t.x][t.y]=='E'||map[t.x][t.y]=='T')
{
t.c=now.c+1;
q.push(t);
}
}
}
}
return -1;  //不能到达,此时返回-1
}
int main()
{
int i,j;
while (cin>>n>>m,m+n)
{
for (i=0;i<n;i++)
{
for (j=0;j<m;j++)
{
cin>>map[i][j];
if (map[i][j]=='Y')
s.x=i,s.y=j;
if (map[i][j]=='T')
e.x=i,e.y=j;
}
}
int sum=bfs();
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: