您的位置:首页 > 其它

POJ 1426 Find The Multiple【BFS】

2016-04-21 19:46 429 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25194 Accepted: 10380 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

Source

Dhaka 2002

100digits是唬人的,直接BFS就行了。。。。。。。

AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define ll long long int
int n;
void bfs()
{
queue<ll>s;
s.push(1);
while(!s.empty())
{
ll now=s.front();
s.pop();
//printf("%lld\n",now);
if(now%n==0)
{
printf("%I64d\n",now);
return ;
}
s.push(now*10);
s.push(now*10+1);
}
return ;
}
int main()
{
while(~scanf("%d",&n))
{
if(n==0)break;
bfs();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 1426