您的位置:首页 > 其它

Pie

2016-04-21 17:11 295 查看
[align=left]Problem Description[/align]
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This
should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them
should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
<br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 

[align=left]Input[/align]
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri
with 1 <= ri <= 10 000: the radii of the pies.<br>
 

[align=left]Output[/align]
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

[align=left]Sample Input[/align]

3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br>

 

[align=left]Sample Output[/align]

25.1327<br>3.1416<br>50.2655<br>

 

[align=left]Source[/align]
NWERC2006
简单题意:
  给出n个pie的半径,还有 m+1个人,每个pie必须是整块的,不能拼接起来,现在要求写出一个程序,求出最大的。
解题思路形成过程:
  正是因为pie不能拼接,所以有了直接在最大那块面积与0之间不断二分即可。
感想:
  典型的二分算法,不算特别难。所以程序自然而然的成型。
AC代码:

#include <iostream>

#include <cstdio>

#include <cmath>

#include <algorithm>

using namespace std;

const double pi = acos(-1.0);

double a[10005];

int n,m;

int check(double mid)

{

    int i;

    int sum = 0;

    for(i = 0; i<n; i++)

    {

        sum+=int(a[i]/mid);

        if(sum>=m)

            return 1;

    }

    return 0;

}

int cmp(double a,double b)

{

    return a>b;

}

int main()

{

    int t,i,j;

    double l,r,mid;

    scanf("%d",&t);

    while(t--)

    {

        scanf("%d%d",&n,&m);

        m++;

        for(i = 0; i<n; i++)

        {

            scanf("%lf",&a[i]);

            a[i] = a[i]*a[i]*pi;

        }

        sort(a,a+n,cmp);

        l = 0;

        r = a[0];

        if(m<n)

            n = m;

        while(r-l>1e-5)

        {

            mid = (r+l)/2;

            if(check(mid))

                l = mid;

            else

                r = mid;

        }

        printf("%.4lf\n",l);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm