您的位置:首页 > 其它

HDU 1020 Encoding

2016-04-21 11:15 344 查看
Encoding
Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 38386    Accepted Submission(s): 17004


Problem Description
Given a string containing only'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to"kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 
 
Input
The first line contains aninteger N (1 <= N <= 100) which indicates the number of test cases. Thenext N lines contain N strings. Each string consists of only 'A' - 'Z' and thelength is less than 10000.
 
 
Output
For each test case, output theencoded string in a line.
 
 
Sample Input
2
ABC
ABBCCC
 
 
Sample Output
ABC
A2B3C
 

 题目大概意思:
给出一串只包含大写字母 “A”-“Z”,我们做如下编码:
1.每一个子串如果包含K个相同的字符,那就写成 “K字母”的样例;

2.长度为1的话,就直接忽略k。

 

第一行包含了整数N (1 <= N <= 100),表示案例个数,每个案例长度小于10000。

 

值得注意的是如果输入的是 ABCCBA

那么输出结果应该是 AB2CBA

附C语言简单代码

#include<stdio.h>
#include<string.h>
int main()
{
int n;
char a[10005];
while(scanf("%d",&n)!=EOF&&n)
{
while(n--)
{
int i;
scanf("%s",a);
for(i=0;i<strlen(a);i++)
{
int count=0;
while(a[i]==a[i+1]) {i++;count++;}
if(count) printf("%d",count+1);
printf("%c",a[i]);
}
printf("\n");
}
return 0;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU 编码