您的位置:首页 > 其它

山东省第五届ACM省赛题——Weighted Median(模拟)

2016-04-20 14:13 302 查看
题目描述

For n elements x1, x2, …, xn with positive integer weights w1, w2, …, wn. The weighted median is the element xk satisfying

and , S indicates

Can you compute the weighted median in O(n) worst-case?

输入

There are several test cases. For each case, the first line contains one integer n(1 ≤  n ≤ 10^7) — the number of elements in the sequence. The following line contains n integer numbers xi (0 ≤ xi ≤ 10^9). The last line contains n integer numbers wi (0 < wi < 10^9).

输出

One line for each case, print a single integer number— the weighted median of the sequence.

示例输入

7

10 35 5 10 15 5 20

10 35 5 10 15 5 20

示例输出

20

本来看到n是10^7就想着是不是有什么高效的算法,结果一看别人做的才知道可以直接模拟过程,从1到n循环,结果700多MS过了。。。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 10000010
using namespace std;
struct Number
{
int x,w;
};
Number num[MAXN];
bool cmp(Number a,Number b)
{
return a.x<b.x;
}
long long sum,first,last,ans;
int main()
{
double S;
int n,m,i;
while(~scanf("%d",&n))
{
sum=0;
for(i=1; i<=n; ++i)
scanf("%d",&num[i].x);
for(i=1; i<=n; ++i)
{
scanf("%d",&num[i].w);
sum+=num[i].w;
}
sort(num+1,num+1+n,cmp);
S=sum*0.5;
first=last=0;
for(i=1;i<=n-1;++i)
{
first+=num[i].w;
last=sum-first-num[i+1].w;
if(first<S&&last<=S)
{
ans=num[i+1].x;
break;
}
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: