您的位置:首页 > 其它

1016 of search

2016-04-19 23:20 246 查看


Red and Black


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 31   Accepted Submission(s) : 16


Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.<br><br>Write
a program to count the number of black tiles which he can reach by repeating the moves described above. <br>

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.<br><br>There are H more lines in the
data set, each of which includes W characters. Each character represents the color of a tile as follows.<br><br>'.' - a black tile <br>'#' - a red tile <br>'@' - a man on a black tile(appears exactly once in a data set) <br>

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). <br>

 

Sample Input

6 9<br>....#.<br>.....#<br>......<br>......<br>......<br>......<br>......<br>#@...#<br>.#..#.<br>11 9<br>.#.........<br>.#.#######.<br>.#.#.....#.<br>.#.#.###.#.<br>.#.#..@#.#.<br>.#.#####.#.<br>.#.......#.<br>.#########.<br>...........<br>11 6<br>..#..#..#..<br>..#..#..#..<br>..#..#..###<br>..#..#..#@.<br>..#..#..#..<br>..#..#..#..<br>7 7<br>..#.#..<br>..#.#..<br>###.###<br>...@...<br>###.###<br>..#.#..<br>..#.#..<br>0 0<br>

 

Sample Output

45<br>59<br>6<br>13<br>

 

Source

Asia 2004, Ehime (Japan), Japan Domestic

 题目要求:一个人在地图上只能走黑色的格子,计算这个人能走过的黑色格子的最大数。

 解题思路:其实和找油田的题目一样,用dfs进行检索,若能走计数加一,最后输出计数即可。
#include <iostream>
#include<string.h>
using namespace std;
#define N 20
int m,n;

int dirctions[4][2]={{0,1},{1,0},{0,-1},{-1,0}};

int visited

;
char map

;
int sum=0;
void DFS(int x,int y)
{

int nx,ny;
for(int i=0;i<4;i++)
{
nx=x+dirctions[i][0];
ny=y+dirctions[i][1];

if(map[nx][ny]=='.'&&nx>=0&&nx<m&&ny>=0&&ny<n&&visited[nx][ny]==0)
{

visited[nx][ny]=1;
sum++;
DFS(nx,ny);

}

}

}

int main()
{
int i,j,x,y;

while(cin>>n>>m)
{
if(m==0||n==0)
break;
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
cin>>map[i][j];
if(map[i][j]=='@')
{
x=i;
y=j;
}
}

memset(visited,0,sizeof(visited));
sum=1;
DFS(x,y);
cout<<sum<<endl;

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: