您的位置:首页 > 其它

ZOJ 3607 Lazier Salesgirl

2016-04-19 22:13 344 查看
Description

Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi. But she is so lazy that she will fall asleep if no customer
comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It's known that she starts to sell bread now and the i-th customer come after ti minutes.
What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.

The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤ 10000. The third line contains n integers 1 ≤ ti ≤
100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10


Sample Output

4.000000 2.500000
1.000000 4.000000
简单递推
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<set>
#include<ctime>
#include<vector>
#include<cmath>
#include<algorithm>
#include<map>
#define ll long long
using namespace std;
const int maxn = 1e5 + 10;
int T, n, p[maxn], t[maxn];

int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d", &n);
for (int i = 1; i <= n; i++) scanf("%d", &p[i]);
for (int i = 1; i <= n; i++) scanf("%d", &t[i]);
int now = 0, w = 0, sum = t[0] = 0;
double ans = 0;
for (int i = 1; i <= n; )
{
while (i <= n&&now >= t[i] - t[i - 1]) sum += p[i++];
if (i&&1.0*sum / (i - 1) > ans)
{
ans = 1.0*sum / (i - 1);
w = now;
}
now = t[i] - t[i - 1];
}
printf("%.6lf %.6lf\n", 1.0*w, 1.0*ans);
}
return 0;
}
温故而知新
#include<map>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define per(i,j,k) for(int i=j;i>=k;i--)
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)
typedef long long LL;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e3 + 10;
int T, n, p
, t
;

int main()
{
for (inone(T); T--;)
{
inone(n);
rep(i, 1, n) inone(p[i]);
rep(i, 1, n) inone(t[i]);
t[0] = 0;
double w = 0, a = 0, g = 0, s = 0;
for (int i = 1; i <= n; )
{
g = t[i] - t[i - 1];
while (i <= n && t[i] - t[i - 1] <= g) s += p[i++];
if (s / (i - 1) > a) a = s / (i - 1), w = g;
}
printf("%.6lf %.6lf\n", w, a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  zoj