您的位置:首页 > 其它

ACM刷题之HDU————hide handkerchief

2016-04-19 21:50 183 查看

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6448 Accepted Submission(s): 2109
Problem Description

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.

Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .

Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place
of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.

So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input

There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output

For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input

3 2
-1 -1


Sample Output

YES


算是之前刷HUD step的时候留下来的题目吧。当时没看懂。
直到我做完Wolf
and Rabbit 的时候。发现这两个是一样的。

其实就是判断两个数是否是互质的数就好了。
下面是ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int main()
{
__int64 a,b,t;
while(scanf("%I64d%I64d",&a,&b)!=EOF)
{
if(a==b&&a==-1)
break;
if(a<b)
{
t=b;
b=a;
a=t;
}
while(a%b!=0)
{
t=a%b;
a=b;
b=t;

}
if(b==1)
printf("YES\n");
else
printf("POOR Haha\n");
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: