您的位置:首页 > 其它

HDU-3746 Cyclic Nacklace ( kmp )

2016-04-19 21:19 323 查看
题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=3746

[align=left]Problem Description[/align]
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys
are busy in choosing christmas presents to send to their girlfriends.
It is believed that chain bracelet is a good choice. However, Things are
not always so simple, as is known to everyone, girl's fond of the
colorful decoration to make bracelet appears vivid and lively, meanwhile
they want to display their mature side as college students. after CC
understands the girls demands, he intends to sell the chain bracelet
called CharmBracelet. The CharmBracelet is made up with colorful pearls
to show girls' lively, and the most important thing is that it must be
connected by a cyclic chain which means the color of pearls are cyclic
connected from the left to right. And the cyclic count must be more than
one. If you connect the leftmost pearl and the rightmost pearl of such
chain, you can make a CharmBracelet. Just like the pictrue below, this
CharmBracelet's cycle is 9 and its cyclic count is 2:



Now
CC has brought in some ordinary bracelet chains, he wants to buy
minimum number of pearls to make CharmBracelets so that he can save more
money. but when remaking the bracelet, he can only add color pearls to
the left end and right end of the chain, that is to say, adding to the
middle is forbidden.
CC is satisfied with his ideas and ask you for help.

[align=left]Input[/align]
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each
test case contains only one line describe the original ordinary chain
to be remade. Each character in the string stands for one pearl and
there are 26 kinds of pearls being described by 'a' ~'z' characters. The
length of the string Len: ( 3 <= Len <= 100000 ).

[align=left]Output[/align]
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

[align=left]Sample Input[/align]

3
aaa

abca

abcde

[align=left]Sample Output[/align]

0
2
5

题目说明 给一串弹珠,已知只能在串头和串尾添加弹珠,求使弹珠串形成一个循环串所需添加的最小弹珠数。样例解析:aaa,循环单元为a;abca,最少添加两个弹珠bc形成abcabc后有循环单元abc;abcde,最少添加abcde形成abcdeabcde后有循环单元abcde。
KMP的应用 设串长为len,则len - next[len]为该串的最小循环子串,代码如下

#include<cstring>
#include<iostream>
using namespace std;

int ne[100005];
int ans;
string mstr, zstr;

void fff(){
memset( ne, 0, sizeof( ne ) );

int k = 0;
for( int p = 1; p < zstr.size();){
while( k > 0 && zstr[p] != zstr[k] )
k = ne[k];
if( zstr[p] == zstr[k] ) k++;
ne[++p] = k;
}
}

int main(){
ios::sync_with_stdio( false );

int T;
cin >> T;
while( T-- ){
cin >> zstr;
fff();
int len = zstr.size();
int t = len - ne[len];
if( len % t == 0 && len / t != 1 ){
cout << 0 << endl;
}
else{
cout << t - len + len / t * t << endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: