您的位置:首页 > 其它

hdu——2602Bone Collector(第一类背包问题)

2016-04-19 20:41 288 查看

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 46744 Accepted Submission(s): 19463



[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1


[align=left]Sample Output[/align]

14


[align=left]Author[/align]
Teddy

[align=left]Source[/align]
HDU 1st “Vegetable-Birds Cup” Programming Open Contest

[align=left]Recommend[/align]
lcy | We have carefully selected several similar problems for you: 1203 2159 1171 2191 2844

第一类背包 for(i=1;i<=n;i++)

for(j=V;j>v[i];j--)

d[j]=max(d[j],d[j-v[i]]+jg[i])
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<set>
#include<map>
#include<sstream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<deque>
using namespace std;
struct bb
{
long long v;
long long jz;
}a[1005];
long long max(long long n,long long m)
{
if(n>=m)return n;
else return m;
}
int main()
{
long long n,m,vv,sum[1005];
cin>>n;
while(n--)
{
cin>>m>>vv;
memset(sum, 0, sizeof(sum));
for(int i=0;i<m;i++)
{
cin>>a[i].jz;
}
for(int i=0;i<m;i++)
{
cin>>a[i].v;
}
for(int i=0;i<m;i++)
{
for(int j=vv;j>=a[i].v;j--)
{
sum[j]=max(sum[j],sum[j-a[i].v]+a[i].jz);
}
}
cout<<sum[vv]<<endl;//注意是vv而不是其他
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: