您的位置:首页 > 其它

ZOJ 3600 Taxi Fare (细节题)

2016-04-19 20:39 381 查看
Description

Last September, Hangzhou raised the taxi fares.

The original flag-down fare in Hangzhou was 10 yuan, plusing 2 yuan per kilometer after the first 3km and 3 yuan per kilometer after 10km. The waiting fee was 2 yuan per five minutes. Passengers need to pay extra 1 yuan as the fuel surcharge.

According to new prices, the flag-down fare is 11 yuan, while passengers pay 2.5 yuan per kilometer after the first 3 kilometers, and 3.75 yuan per kilometer after 10km. The waiting fee is 2.5 yuan per four minutes.

The actual fare is rounded to the nearest yuan, and halfway cases are rounded up. How much more money does it cost to take a taxi if the distance is d kilometers and the waiting time is t minutes.

Input

There are multiple test cases. The first line of input is an integer T ≈ 10000 indicating the number of test cases.

Each test case contains two integers 1 ≤ d ≤ 1000 and 0 ≤ t ≤ 300.

Output

For each test case, output the answer as an integer.

Sample Input

4
2 0
5 2
7 3
11 4


Sample Output

0
1
3
5


思路: 注意不要直接做单价的差值,那样会wrong到死.... The actual fare is rounded to the nearest yuan, and halfway cases are rounded up

这句话很关键啊!!!!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int T,i,j,d,m,ans1,ans2;
double t1,t2;
scanf("%d",&T);
while(T--) {
t1=t2=0;
scanf("%d%d",&d,&m);
if(d>10) {
t1+=3.0*(d-10);
t2+=3.75*(d-10);
d=10;
}
if(d>3) {
t1+=2.0*(d-3);
t2+=2.5*(d-3);
}
t1+=0.4*m;
t2+=0.625*m;
ans1=(int)(t1+0.5);
ans2=(int)(t2+0.5);
//		printf("%lf %lf\n",t1,t2);
printf("%d\n",ans2-ans1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: