您的位置:首页 > 大数据 > 人工智能

03-树3 Tree Traversals Again (25分)

2016-04-19 19:52 459 查看
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop();
push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.



Figure 1


Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le
30≤30)
which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN).
Then 2N2N lines
follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.


Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.


Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop



Sample Output:

3 4 2 6 5 1


#include<iostream>
using namespace std;
#include<cstdio>
#include<cstdlib>
#include<stack>
#include<string>
int preorder[40],medorder[40],postorder[40];
void solve(int prel,int medl,int postl,int n){
//陈越老师说的递归!一开始用建树的方法好难没有成功
//这个里面的变量分别是前序的起始下标,中序的起始下标和后序的。最后一个是排序的数组个数
int root;
int i;
if(n==0) return;
if(n==1) {
postorder[postl]=preorder[prel];
return;
}
root=preorder[prel];
postorder[postl+n-1]=root;
for(i=0;i<n;i++){
if(medorder[medl+i] == root ) break;
}
int l,r;
l=i;r=n-l-1;
solve(prel+1,medl,postl,l);
solve(prel+l+1,medl+l+1,postl+l,r);
}

int main(){
stack<int> tree;
int n;
int i,j;
cin>>n;
string inputtemp;
int tempnum;
for(i=0,j=0;i<n||j<n;){
cin>>inputtemp;
if(inputtemp[1]=='u'){
cin>>tempnum;
tree.push(tempnum);
preorder[i]=tempnum;
i++;
}
else{
tempnum=tree.top();
tree.pop();
medorder[j]=tempnum;
j++;
}
}
solve(0,0,0,n);
for(i=0;i<n-1;i++){
cout<<postorder[i];
cout<<' ';
}
cout<<postorder[n-1];
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: