您的位置:首页 > 其它

hdu-5003 Osu!(水题)

2016-04-19 14:58 417 查看
题目链接:

Osu!

time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/65536 K (Java/Others)

[align=left]Problem Description[/align]
[align=left] [/align]
Osu! is a famous music game that attracts a lot of people. In osu!, there is a performance scoring system, which evaluates your performance. Each song you have played will have a score. And the system will sort all you scores in descending order. After that, the i-th song scored ai will add 0.95^(i-1)*ai to your total score.

Now you are given the task to write a calculator for this system.

[align=left]Input[/align]
[align=left] [/align]
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains an integer n, denoting the number of songs you have played. The second line contains n integers a1, a2, ..., an separated by a single space, denoting the score of each song.

T<=20, n<=50, 1<=ai<=500.

[align=left]Output[/align]
[align=left] [/align]
For each test case, output one line for the answer.

Your answers will be considered correct if its absolute error is smaller than 1e-5.

[align=left]Sample Input[/align]
[align=left] [/align]

1

2

530 478

[align=left]Sample Output[/align]
[align=left] [/align]

984.1000000000

题意:
水题不说了;

思路:

AC代码:

#include <bits/stdc++.h>
using namespace std;
const int N=1e6+5;
typedef long long ll;
const ll mod=1e9+7;
int t,n;
int a[1000];
int cmp(int x,int y)
{
return x>y;
}
int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
double ans=0;
sort(a+1,a+n+1,cmp);
for(int i=1;i<=n;i++)
{
ans+=pow(0.95,i-1)*(double)a[i];
}
printf("%.10lf\n",ans);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: