您的位置:首页 > 其它

hdu——1686Oulipo(kmp)

2016-04-19 12:06 447 查看

Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9378 Accepted Submission(s): 3746



[align=left]Problem Description[/align]
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

[align=left]Input[/align]
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

[align=left]Output[/align]
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

[align=left]Sample Input[/align]

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN


[align=left]Sample Output[/align]

1
3
0


[align=left]Source[/align]
华东区大学生程序设计邀请赛_热身赛

[align=left]Recommend[/align]
lcy

学习一种新的算法 用find会超时 next数组 找出前缀最大的数 当不匹配时返回next[j] 在hud中最好将next数组改个名字
#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int next[100010];
int sum;
void GetNext(string n)
{
long long i=0,j=-1;
next[0]=-1;
while(i<n.size())
{
if(j==-1||n[i]==n[j])
{
++j;
++i;
if(n[i]!=n[j])
next[i]=j;
else
next[i]=next[j];
}
else {
j=next[j];
}

}
}//next找出前缀和后缀相同最大的数
void kmp(string n,string m)
{
int i=0,j=0;
while(i<m.size())
{
if(j==-1||n[j]==m[i])
{
i++;
j++;
}
else j=next[j];
if(j==n.size())
{
sum=sum+1;
j=next[j];
}
}
}
int main()
{
string s1,s2;
int n,m,i,j,k;
ios::sync_with_stdio(false); //取消同步 防止cin和cout超时
cin>>n;
if(n<=0)return 0;
while(n--)
{	sum=0;
memset(next,0,sizeof(next));
cin>>s1>>s2;
if(s2.size()<s1.size())
{	cout<<"0"<<endl;
continue;
}

GetNext(s1);
kmp(s1,s2);
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: