您的位置:首页 > 其它

HDU 1078 FatMouse and Cheese 记忆化搜索模板 dp

2016-04-18 22:33 543 查看

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7629 Accepted Submission(s): 3158



[align=left]Problem Description[/align]
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0
and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

[align=left]Input[/align]
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.

[align=left]Output[/align]
For each test case output in a line the single integer giving the number of blocks of cheese collected.

[align=left]Sample Input[/align]

3 1
1 2 5
10 11 6
12 12 7
-1 -1


[align=left]Sample Output[/align]

37


题目大意:一只肥老鼠在一座城市里卖弄藏了一些奶酪,那个城市地方的布局是n阶方阵的形式,奶酪在这个方阵中……它要去吃奶酪,然而有只猫盯着它,所以最多跑k步,不然会被kill,然后它每次吃的奶酪只能增多,求最大值。

思路:应该利用记忆化搜索的方法,利用数组不断记录下每次吃得最多的奶酪,用dfs给出,当模板来记了,,,

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[105][105],a[105][105],f[4][2]={1,0,-1,0,0,1,0,-1};
int n,k;
int dfs(int x,int y)
{
int temp,maxn=0,mx,my;
if(dp[x][y]) //遍历
return dp[x][y];
for(int i=1;i<=k;i++)
{
for(int j=0;j<4;j++)//从上至下
{
mx=x+f[j][0]*i;//x
my=y+f[j][1]*i;//y
if(mx>=0&&mx<n&&my>=0&&my<n&&a[mx][my]>a[x][y])//每次在k的范围内找到最大的奶酪
{
temp=dfs(mx,my);
if(temp>maxn)
maxn=temp;
}

}
}
dp[x][y]=maxn+a[x][y];
return dp[x][y];
}
int main()
{
while(~scanf("%d%d",&n,&k)&&(n!=-1||k!=-1))
{
memset(dp,0,sizeof(dp));
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
scanf("%d",&a[i][j]);
cout<<dfs(0,0)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: