您的位置:首页 > 其它

POJ-2635 The Embarrassed Cryptographer

2016-04-18 22:06 447 查看
Description


The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company.
The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.

What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users
keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.
Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of
the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

Source
Nordic 2005

题目大意:给你一个高精度数n和一个单精度数l,问n的第一个质因数是否小于l。

分析: WA了好久才过,直接暴力会超时,要用到压位高精度。

#include <cstdio>
#include <cstring>
#include <iostream>
#define MAXN 1000000
using namespace std;
int num,l,prim[MAXN+1],f[101];
bool notprim[MAXN+1];
char s[101];
int Size(int x)
{
if(x == 0) return 1000;
if(x == 2) return 100;
return 10;
}
int main()
{
for(int i = 2;i <= MAXN;i++)
if(!notprim[i])
{
prim[++num] = i;
for(int j = 2*i;j <= MAXN;j += i)
notprim[j] = true;
}
while(scanf("%s%d",s,&l) && l)
{
int length = strlen(s),tot = 0;
bool flag = false;
for(int i = 0;i < length;i++)
{
if(i % 3 == 0) f[++tot] = s[i] - '0';
else f[tot] = f[tot]*10 + s[i] - '0';
}
for(int i = 1;i <= num && prim[i] < l;i++)
{
int now = 0;
for(int j = 1;j < tot;j++)
now = (now*1000 + f[j]) % prim[i];
now = (now*Size(length % 3) + f[tot]) % prim[i];
if(now == 0)
{
cout<<"BAD "<<prim[i]<<endl;
flag = true;
break;
}
}
if(!flag) cout<<"GOOD"<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: