您的位置:首页 > 其它

Program2_1020

2016-04-18 21:56 148 查看
我现在做的是第二专题编号为1020的试题,具体内容如下所示:

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 22 Accepted Submission(s) : 14
[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always
be 1.<br><br><img src=../../data/images/1016-1.gif><br>

[align=left]Input[/align]
n (0 < n < 20).<br>

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>

[align=left]Sample Input[/align]

6<br>8<br>


[align=left]Sample Output[/align]

Case 1:<br>1 4 3 2 5 6<br>1 6 5 2 3 4<br><br>Case 2:<br>1 2 3 8 5 6 7 4<br>1 2 5 8 3 4 7 6<br>1 4 7 6 5 8 3 2<br>1 6 7 4 3 8 5 2<br>


[align=left]Source[/align]
Asia 1996, Shanghai (Mainland China)

简单题意:两个相邻圆圈之和为素数

解题思路:从题意中不难看出,和以前的试题很相似,用dfs进行深搜,判断相邻的两个之和是否为素数

编写代码:#include <iostream>

#include <algorithm>

#include <string.h>

#include <cmath>

using namespace std;

const int maxn=25;

bool visit[maxn];

int num[maxn];

int n;

bool prime(int n)

{

if(n==1)

return false;

if(n==2)

return true;

if(n%2==0)

return false;

for(int i=3;i<=(int)sqrt(n);i+=2)

if(n%i==0)

return false;

return true;

}

void dfs(int step)

{

if(step>n&&prime(num
+num[1]))

{

for(int i=1;i<=n-1;i++)

cout<<num[i]<<" ";

cout<<num
<<endl;

}

for(int i=2;i<=n;i++)

{

num[step]=i;

if(prime(num[step]+num[step-1])&&!visit[i])

{

visit[i]=1;

dfs(step+1);

visit[i]=0;

}

}

}

int main()

{

int c=1;

while(cin>>n)

{

cout<<"Case "<<c++<<":"<<endl;

memset(visit,0,sizeof(visit));

num[1]=1;

dfs(2);

cout<<endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: