您的位置:首页 > 其它

PAT Have Fun with Numbers

2016-04-18 20:56 375 查看
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with kk digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes

2469135798

【题目大意】:有一类像123456789的数,将其乘2后的数位组成是一样的(246913578)。同样的数还有1234567899等等

我的代码:

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
int i, j=0, len, temp, pl,len1;
int a = 0;
char ch[100] = { 0 };
char zh[100] = { 0 };
gets(ch);
len = strlen(ch);
for (i = len - 1; i >= 0; i--)
{
temp = ch[i] - '0';
pl = temp * 2;
zh[j++] = pl-(pl+a)/10*10 + a + '0';

if (pl >= 10)
a = pl / 10;
else
a = 0;

}
if (a == 1)
{
zh[len] = 1 + '0';
zh[len + 1] = '\0';
printf("No\n");
len1 = strlen(zh);
for (j = len1 - 1; j >= 0; j--)
printf("%c", zh[j]);
return 0;
}
else
zh[len] = '\0';

len1 = strlen(zh);
for (j = 0; j < len1; j++)
{
for (i = 0; i < len; i++)
{
if (zh[j] == ch[i])
break;
}
if (i == len)
printf("No\n");

}
if (j==len1)
printf("Yes\n");
for (j = len1 - 1; j >= 0; j--)
printf("%c", zh[j]);
return 0;
}


判定结果:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c PAT