您的位置:首页 > 其它

hdu 2586 How far away ? 带权lca

2016-04-18 20:49 459 查看

How far away ?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)


[align=left]Problem Description[/align]
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

[align=left]Input[/align]
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

[align=left]Output[/align]
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

[align=left]Sample Input[/align]

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

[align=left]Sample Output[/align]

10
25
100
100

[align=left]Source[/align]
ECJTU 2009 Spring Contest
思路:在lca的基础上加dis(距离根的距离)数组,在dfs处理好,ans=dis[a]-2*dis[LCA(a,b)]+dis[b];

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstring>
#include<vector>
#include<list>
#include<set>
#include<map>
#define true ture
#define false flase
using namespace std;
#define ll long long
#define inf 0xfffffff
int scan()
{
int res = 0 , ch ;
while( !( ( ch = getchar() ) >= '0' && ch <= '9' ) )
{
if( ch == EOF )  return 1 << 30 ;
}
res = ch - '0' ;
while( ( ch = getchar() ) >= '0' && ch <= '9' )
res = res * 10 + ( ch - '0' ) ;
return res ;
}
#define maxn 40010
#define M 22
struct is
{
int v,next,w;
} edge[maxn*2];
int deep[maxn],jiedge;
int dis[maxn];
int head[maxn];
int rudu[maxn];
int fa[maxn][M];
void add(int u,int v,int w)
{
jiedge++;
edge[jiedge].v=v;
edge[jiedge].w=w;
edge[jiedge].next=head[u];
head[u]=jiedge;
}
void dfs(int u)
{
for(int i=head[u]; i; i=edge[i].next)
{
int v=edge[i].v;
int w=edge[i].w;
if(!deep[v])
{
dis[v]=dis[u]+edge[i].w;
deep[v]=deep[u]+1;
fa[v][0]=u;
dfs(v);
}
}
}
void st(int n)
{
for(int j=1; j<M; j++)
for(int i=1; i<=n; i++)
fa[i][j]=fa[fa[i][j-1]][j-1];
}
int LCA(int u , int v)
{
if(deep[u] < deep[v]) swap(u , v) ;
int d = deep[u] - deep[v] ;
int i ;
for(i = 0 ; i < M ; i ++)
{
if( (1 << i) & d )  // 注意此处,动手模拟一下,就会明白的
{
u = fa[u][i] ;
}
}
if(u == v) return u ;
for(i = M - 1 ; i >= 0 ; i --)
{
if(fa[u][i] != fa[v][i])
{
u = fa[u][i] ;
v = fa[v][i] ;
}
}
u = fa[u][0] ;
return u ;
}
void init()
{
memset(head,0,sizeof(head));
memset(fa,0,sizeof(fa));
memset(rudu,0,sizeof(rudu));
memset(deep,0,sizeof(deep));
jiedge=0;
}
int main()
{
int x,n;
int t;
scanf("%d",&t);
while(t--)
{
init();
scanf("%d%d",&n,&x);
for(int i=1; i<n; i++)
{
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
add(u,v,w);
rudu[v]++;
}
for(int i=1;i<=n;i++)
{
if(!rudu[i])
{
deep[i]=1;
dis[i]=0;
dfs(i);
break;
}
}
st(n);
while(x--)
{
int a,b;
scanf("%d%d",&a,&b);
printf("%d\n",dis[a]-2*dis[LCA(a,b)]+dis[b]);
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: