您的位置:首页 > 运维架构

acm 2 1004 Toxophily

2016-04-17 20:15 387 查看
1.1004

2.

[align=left][/align]
Problem Description

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.

We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.

 

Input

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of
the fruit. v is the arrow's exit speed.

Technical Specification

1. T ≤ 100.

2. 0 ≤ x, y, v ≤ 10000.

 

Output

For each test case, output the smallest answer rounded to six fractional digits on a separated line.

Output "-1", if there's no possible answer.

Please use radian as unit.

 

Sample Input

3

0.222018 23.901887 121.909183

39.096669 110.210922 20.270030

138.355025 2028.716904 25.079551

 

Sample Output

1.561582

-1

-1

3.鲍勃最近迷上射箭。假设鲍勃在点(0,0),他要到附近的一棵树上的果实拍。他可以调整角度来修正轨迹。不幸的是,他总是失败了。你能帮助他吗?

现在给出物体的坐标,请计算在鲍勃点箭头和轴之间的夹角。假设G= 9.8n/m。

输入

输入由几个测试用例组成。输入的第一行包含一个整数,表示测试用例的数目。每一个测试用例都是在一个分离的直线上,它由三个浮点数字组成:*,*,和*,表示水果的坐标。箭头的出口速度。

技术规范

1。T≤100。

2。0≤X、Y、V≤10000。

输出

对于每一个测试案例,输出一个分离的线的六个小数位数的最小答案。

输出“- 1”,如果没有可能的答案。

请使用弧度单位。

样本输入



0.222018 23.901887 121.909183

39.096669 110.210922 20.270030

138.355025 2028.716904 25.079551

示例输出

一点五六一五八二

- 1

- 1

4.三分吧T-T,而且用物理上的正交分解公式,把物体运动方向正交分解得出公式

 x^2*g/(2*v^2)*tan^2(ß) - x*tan(ß) +y + x^2*g/(2*v^2) = 0

 a = g*pow(x,2)/(2*pow(v,2)); b = -x; c = y + g*pow(x,2)/(2*pow(v,2));

1. x==0&&y==0时,ß = 0;

2. x==0&&y>0时,ß=90;

3. 方程无解 ß=-1;

4. 解《0,ß=-1;(0<=ß<=90)

5.#include<cstdio>  

#include<cmath>

#include<iostream>  

using namespace std;  

#define PI 3.141592653  

#define g 9.8  

int main()

{  

    

    int T;   

    double x,y,v;  

    cin>>T;  

    while(T--)
{  

        scanf("%lf%lf%lf",&x,&y,&v);  

        int i,flag=0;  

        double low,high,mid;  

        low=0; high=PI/2;  

        for(i=0;i<1000;i++)
{  

            double a,b,c;  

            mid=(low+high)/2;  

            a=-g*tan(mid)/(v*v*sin(2*mid));  

            b=v*v*sin(2*mid)/(2*g);  

            c=v*v*sin(mid)*sin(mid)/(2*g);  

            if(fabs(y-(a*(x-b)*(x-b)+c))<0.0000001)
{  

                flag=1;  

                break;  

            }  

            if(y>a*(x-b)*(x-b)+c)  

                low=mid;  

            else  

                high=mid;  

        }  

        if(flag==0)  

            printf("-1\n");  

        else  

            printf("%.6lf\n",mid);  

    }  

    return 0;  

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: