您的位置:首页 > 其它

POJ 1003

2016-04-17 17:35 351 查看
Hangover
TimeLimit: 1000MS Memory Limit: 10000K
TotalSubmissions: 115927 Accepted: 56545
DescriptionHow far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.InputThe input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.OutputFor each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.Sample Input1.003.710.045.190.00Sample Output3 card(s)61 card(s)1 card(s)273 card(s)来源: <http://poj.org/problem?id=1003
#include <stdio.h>
int main(void)
{
double da_tmp[300];
int i_use_len = 1;
double d_max_value=0;
double d_input;
for(;d_max_value < 5.2;++i_use_len)
{
da_tmp[i_use_len] = da_tmp[i_use_len-1] + 1.0/(i_use_len+1);
d_max_value = da_tmp[i_use_len];
}
while(scanf("%lf",&d_input))
{
int i;
if(d_input < 0.01)
{
break;
}
for(i=1;i<=i_use_len;++i)
{
if(da_tmp[i]>=d_input)
    {
printf("%d card(s)\n",i);
    break;
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: