您的位置:首页 > 其它

并查集例题-The Suspects

2016-04-17 15:22 323 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 30831 Accepted: 14987
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

题目大意就是说一开始只有0号是感染疾病的,然后给出一组数据,去查找跟他相关的人,看看一共有多少人感染疾病
这种题一看就知道是并查集了,他还稍微变了一下,不像最原始的并查集,家庭血脉那样,就是你要怎么选取人员去两个比较。

我一开始想复杂了,是选择前后匹配的,但是后来发现直接选取第一个,和后面全部一一比较就可以了啊

然后我就。。。一直wa,好奇怪,尝试了很多次才过了

下面是我过了的代码,我直接把路径压缩和通过集合的个数比较才合并都砍掉了,还是很简短的

#include<iostream>
using namespace std;
#define N 30005

int father
,rank
;

void refresh(int n)
{
for(int i = 0; i < n; i++)
{
father[i] = i;
rank[i] = 1;
}
}

int find(int x)
{
if(x != father[x])
x = find(father[x]);//单纯的寻找父节点,砍掉路径压缩

return x;
}

void Union(int x,int y)
{
father[y] = x;
rank[x] += rank[y];//砍掉比较两个rank,就是集合的元素个数,再把小的并进大的里面
}

int main()
{
int n,m,t;
int a,b,k,x,y;
while(1)
{
cin >> n >> m;
if(n == 0 && m == 0)
break;
refresh(n);
for(int i = 0; i < m; i++)
{
cin >> k >> a;
x = find(a);
for(int j=1;j<k;j++)
{
cin >> b;
y = find(b);
if(x != y)
Union(x,y);
}
}
cout<<rank[find(0)]<<endl;
}
return 0;
}真的很奇怪,为什么把路径压缩和比较rank就会wa,下面是我wa的代码,一直没弄懂
#include<iostream>
using namespace std;
#define N 30005

int father
,rank
;

void refresh(int n)
{
for(int i = 0; i < n; i++)
{
father[i] = i;
rank[i] = 1;
}
}

int find(int x)
{
int temp,root;
temp = x;
while(x != father[x])
x = father[x];

root = x;
x = temp;

while(x != father[x])
{
temp = father[x];
father[x] = root;
x = temp;
}

return root;
}

void Union(int x,int y)
{
if(rank[x]>=rank[y])
{
father[y] = x;
rank[x] += rank[y];
}
else
{
father[x] = y;
rank[y] += rank[x];
}
}

int main()
{
int n,m,t;
int a,b,k,x,y;
while(1)
{
cin >> n >> m;
if(n == 0 && m == 0)
break;
refresh(n);
for(int i = 0; i < m; i++)
{
cin >> k >> a;
x = find(a);
for(int j=1;j<k;j++)
{
cin >> b;
y = find(b);
if(x != y)
Union(x,y);
}
}
cout<<rank[find(0)]<<endl;
}
return 0;
}

我专门看了网上很多人写这题,都是这样写的,模版大体上是不用改的,但是为啥他们过了我挂了。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: