您的位置:首页 > 其它

【杭电-oj】-1161-字母全部化为小写

2016-04-17 13:20 330 查看
Problem Description

Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure
to be able in the Bob article English letter to turn completely the small letter.

Input

The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation

composition, the writing length does not surpass 1000 characters.

Output

For each test case, you should output an only line, after namely the result of transforms the lowercase letter.

Sample Input

weLcOmE tO HDOj Acm 2005!


Sample Output

welcome to hdoj acm 2005!


输入一个句子,有多个单词,每个单词中间用空格隔开,用getchar而不用scanf,scanf默认遇到空格结束输入。

#include<stdio.h>
#include<string.h>
int main()
{
int l;
char a[2000];
while(gets(a))
{
l=strlen(a);
for(int i=0;i<l;i++)
{
if(a[i]>='a'&&a[i]<='z')
printf("%c",a[i]);
else if(a[i]>='A'&&a[i]<='Z')
printf("%c",a[i]+32);
else
printf("%c",a[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: