您的位置:首页 > 其它

POJ 3723 Conscription

2016-04-17 09:29 435 查看
Conscription

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10518Accepted: 3715
Description

Windy has a country, and he wants to build an army to protect his country. He has picked up
N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost.
If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to
find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.

The first line of each test case contains three integers, N, M and
R.

Then R lines followed, each contains three integers xi,
yi and di.

There is a blank line before each test case.

1 ≤ N, M ≤ 10000

0 ≤ R ≤ 50,000

0 ≤ xi < N

0 ≤ yi < M

0 < di < 10000

Output
For each test case output the answer in a single line.
Sample Input
2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output
71071
54223


Kruskal + 并查集求最大生成树

#include <stdio.h>
#include <stdlib.h>
int N, M, R;
int group[20005];
struct node
{
int u;
int v;
int w;
} map[50005];
int cmp(const void *a, const void *b)
{
return (*(node*)b).w - (*(node*)a).w;
}
int find(int x)
{
if(group[x] == x)
return x;
else
return group[x] = find(group[x]);
}
bool unite(int i, int j)
{
i = find(i);
j = find(j);
if(i != j)
{
group[i] = j;
return false;
}
return true;
}
int main()
{
int T, A, B, C, i, sum;
scanf("%d", &T);
while(T--)
{
scanf("%d%d%d", &N, &M, &R);
for(i = 1; i <= R; i++)
{
scanf("%d%d%d", &A, &B, &C);
map[i].u = A + 1;
map[i].v = B + N + 1;
map[i].w = C;
}
qsort(&map[1], R, sizeof(map[1]), cmp);
for(i = 1; i <= N + M; i++)
group[i] = i;
sum = 10000 * (N + M);
for(i = 1; i <= R; i++)
if(!unite(map[i].u, map[i].v))
sum -= map[i].w;
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: