您的位置:首页 > 其它

POJ 2488 A Knight's Journey

2016-04-17 09:11 267 查看
A Knight's Journey

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 38688Accepted: 13121
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a
p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the
chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


给出国际象棋的的一个棋盘,里面有一个马,给出所在棋盘的长和宽,问从任意一点开始,

能否不重复的走遍棋盘上的每一点,若能就输出一个字符串,其中字母代表行,数字代表列,不能就输出impossible

经典的“骑士游历”问题,DFS水题一道

1、 题目要求以"lexicographically"方式输出,也就是字典序...

2、国际象棋的棋盘,行为数字p;列为字母q

3、网上有同学说 这道题最后一组数据后是有空行的会PE...,我测试过,不会的,能AC

#include <stdio.h>
#include <string.h>
int p, q;
bool vis[30][30];
char s[2000];
int flag;
int len;
int dx[8] = {-2,-2,-1,-1,1,1,2,2};
int dy[8] = {-1,1,-2,2,-2,2,-1,1};
void DFS(int i, int j, int n)
{
if(flag)
return;
if(i < 1 || j < 1 || i > q || j > p || vis[i][j])
return;
vis[i][j] = true;
n++;
s[len++] = i - 1 + 'A';
s[len++] = j + '0';
if(n == p * q)
{
flag = 1;
for(i = 0; i < 2 * p * q; i++)
printf("%c", s[i]);
printf("\n");
return;
}
for(int a = 0; a < 8; a++)
{
DFS(i + dx[a], j + dy[a], n);
}
len-=2;
vis[i][j] = false;
}
int main()
{
int n, count = 1;
scanf("%d", &n);
while(n--)
{
flag = 0;
len = 0;
memset(vis, false, sizeof(vis));
scanf("%d%d", &p, &q);
printf("Scenario #%d:\n", count++);
DFS(1, 1, 0);
if(!flag)
{
printf("impossible\n");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: