您的位置:首页 > 其它

POJ 3259 Wormholes

2016-04-17 09:10 281 查看
Wormholes

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 40699Accepted: 14914
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms
comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,
M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to
F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N,
M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: a bidirectional path between
S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: A one way path from S to
E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output
NO
YES

Hint
For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

带负圈的最短路径问题,用Bellman_Ford算法或者SPFA算法都能过

#include <stdio.h>
#include <string.h>
int N, M, W;
struct node
{
int u;
int v;
int w;
} map[5500];
int dist[505];
bool Bellman_Ford()
{
int i, j;
for(i = 1; i < N; i++)
for(j = 1; j <= 2*M+W; j++)
if(dist[map[j].u] + map[j].w < dist[map[j].v])
dist[map[j].v] = dist[map[j].u] + map[j].w;
for(i = 1; i <= 2*M+W; i++)
if(dist[map[i].u] + map[i].w < dist[map[i].v])
return true;
return false;
}
int main()
{
int F, i, j, S, E, T;
scanf("%d", &F);
while(F--)
{
memset(dist, 0x3f, sizeof(dist));
scanf("%d%d%d", &N, &M, &W);
for(i = 1; i <= M; i++)
{
scanf("%d%d%d", &S, &E, &T);
map[2*i-1].u = S;
map[2*i-1].v = E;
map[2*i-1].w = T;
map[2*i].u = E;
map[2*i].v = S;
map[2*i].w = T;
}
for(i = 1; i <= W; i++)
{
scanf("%d%d%d", &S, &E, &T);
map[2*M+i].u = S;
map[2*M+i].v = E;
map[2*M+i].w = -T;
}
dist[1] = 0;
if(Bellman_Ford())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: