您的位置:首页 > 其它

zoj 2110

2016-04-17 08:06 316 查看
A - Tempter of the Bone
Crawling in process...
Crawling failed
Time Limit:2000MS    
Memory Limit:65536KB     64bit IO Format:%lld & %llu

Submit

Status
Practice
ZOJ 2110

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this
maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

....

3 4 5

S.X.

..X.

...D

0 0 0



Sample Output


NO

YES

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
char map[10][10];
bool flag[10][10];
int way[4][2]={ 0,1,0,-1,1,0,-1,0 };
int ni,nj,n,m;
bool dfs( int s,int x,int y )
{
int i,xx,yy;
if( map[x][y]=='D' && s==0 )
return true;
if( map[x][y]=='D' && s!=0 )
return false; //递归出口
if( s<=0 )
return false;
for( i=0;i<4;i++ )
{
xx=x+way[i][0] ;
yy=y+way[i][1];
if( xx>=0 && xx<n && yy>=0 && yy<m && map[xx][yy]!='X' && !flag[xx][yy] )
{
flag[xx][yy]=1;
if(dfs(s-1,xx,yy))
return true;
flag[xx][yy]=0;
}
}
return false;
}

int main()
{
int t,i,j;
while( cin>>n>>m>>t && ( n+m+t ) )
{
memset( flag,0,sizeof(flag) );
for( i=0;i<n;i++ )
{
for( j=0;j<m;j++ )
{
cin>>map[i][j];
if( map[i][j]=='S' )
ni=i , nj=j ;
}
}
flag[ni][nj]=1;
if( dfs( t,ni,nj ) )
printf( "YES\n" );
else
printf( "NO\n" );
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: