您的位置:首页 > 其它

HDU2602 Bone Collector 01背包DP 模板题

2016-04-16 20:57 483 查看


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 46602    Accepted Submission(s): 19405


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 

Author

Teddy

 

Source

HDU 1st “Vegetable-Birds Cup” Programming
Open Contest

 
给出若干物体的重量和价值,问在一定重量内能得的最大价值。复杂度O(V*W)。

int dp[1009][1009];//从第i个物品开始,挑选重量不大于j时的最大值

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <time.h>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int T,N,W;
int value[1009];
int weight[1009];
int dp[1009][1009];//从第i个物品开始,挑选重量不大于j时的最大值

void solve(){
memset(dp,0,sizeof(dp));
for(int i=N;i>=1;i--){
for(int j=0;j<=W;j++){
if(j<weight[i]){
dp[i][j]=dp[i+1][j];
}
else{
dp[i][j]=max(dp[i+1][j],dp[i+1][j-weight[i]]+value[i]);
}
}
}
}
int main(){
cin>>T;
while(T--){
cin>>N>>W;

for(int i=1;i<=N;i++){
scanf("%d",&value[i]);
}
for(int i=1;i<=N;i++){
scanf("%d",&weight[i]);
}

solve();
cout<<dp[1][W]<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: