您的位置:首页 > 大数据 > 人工智能

ACM--单调栈--Bad Hair Day--POJ--3250--水

2016-04-16 15:49 459 查看
POJ地址:http://poj.org/problem?id=3250

Bad Hair Day

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows
in front of her (namely cowsi+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

=
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4

Cow#2 can see no cow's hairstyle

Cow#3 can see the hairstyle of cow #4

Cow#4 can see no cow's hairstyle

Cow#5 can see the hairstyle of cow 6

Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output

Line 1: A single integer that is the sum of c1 through cN.
Sample Input
6
10
3
7
4
12
2

Sample Output
5


================================华丽的分割线=============================

单调栈的入门题:单调栈就是维护一个栈,栈中的元素都保持着单调递增或递减的顺序。

题目意思:有n只牛站在一排,给出队伍中每只牛的高度,每只牛只能看到它右边比它矮的牛,求所有的牛能看到的牛数之和。

当我们新加入一个高度值时,如果栈中存在元素小于新加入的高度值,那这个牛肯定看不见这个高度的牛,就把这个元素弹栈。

每次加入新元素,并执行完弹出操作后,栈中元素个数便是可以看见这个牛的“牛数”。

#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;
int main(void){
int n;
stack <long long>sta;
if(scanf("%d",&n)!=EOF){
long long  result=0;
long long  x;
cin>>x;
//将第一个元素入栈
sta.push(x);
for(int i=1;i<n;i++){
cin>>x;
while(!sta.empty()&&sta.top()<=x){
sta.pop();
}
result+=sta.size();
sta.push(x);
}
cout<<result<<endl;
//清空栈
while(!sta.empty()){
sta.pop();
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: