您的位置:首页 > 其它

FZU 2150 Fire Game(BFS)

2016-04-16 10:53 316 查看
Problem 2150 Fire Game

Accept: 1302 Submit: 4569

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids
which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x,
y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted
in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.



Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass
in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10



Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.



Sample Input

43 3.#.###.#.3 3.#.#.#.#.3 3...#.#...3 3###..##.#



Sample Output


Case 1: 1Case 2: -1Case 3: 0Case 4: 2

枚举两个点然后BFS

#include <iostream>
#include <string.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <queue>

using namespace std;
#define MAX 10000000
struct Node
{
int x;
int y;
int t;
Node(){};
Node(int x,int y,int t)
{
this->x=x;
this->y=y;
this->t=t;
}
};
char m[15][15];
int vis[15][15];
int dir[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int n,m1;
int t;
int ans;
int res;
void bfs(Node a,Node b)
{
queue<Node> q;
q.push(a);
q.push(b);
vis[a.x][a.y]=1;
vis[b.x][b.y]=1;
while(!q.empty())
{
Node term=q.front();
q.pop();
ans=max(ans,term.t);
bool tag=false;
for(int i=0;i<4;i++)
{
int xx=term.x+dir[i][0];
int yy=term.y+dir[i][1];
if(xx<1||xx>n||yy<1||yy>m1)
continue;
if(m[xx][yy]=='.'||vis[xx][yy])
continue;
vis[xx][yy]=1;tag=true;
q.push(Node(xx,yy,term.t+1));
}

}
}
int judge()
{
for(int i=1;i<=n;i++)
for(int j=1;j<=m1;j++)
if(m[i][j]=='#'&&!vis[i][j])
return 0;
return 1;
}
int main()
{
int t;
scanf("%d",&t);
int cas=0;
while(t--)
{
scanf("%d%d",&n,&m1);
for(int i=1;i<=n;i++)
scanf("%s",m[i]+1);
ans=0;res=MAX;
bool flag=false;
bool flag2=false;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m1;j++)
{
for(int k=1;k<=n;k++)
{
for(int p=1;p<=m1;p++)
{
if(m[i][j]=='#'&&m[k][p]=='#')
{
flag2=true;
memset(vis,0,sizeof(vis));
ans=0;
bfs(Node(i,j,0),Node(k,p,0));
if(judge())
res=min(res,ans);
}
}
}
}
}
if(res==MAX)
res=-1;
printf("Case %d: %d\n",++cas,res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: