您的位置:首页 > 其它

POJ 1087 A Plug for UNIX 最大流

2016-04-15 21:28 369 查看
Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.

Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling

irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.

Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn’t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.

In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric

characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D


Sample Output

1


题目分析:

这题一看就不想做….其一是因为英文题,还这么长,那么多字,其二是对字符串的操作,比较麻烦,但是其实这题理解了还是不难的。

题意:

有n种插座,每种插座只有一个,m个用电器,每个用电器有特定的插座,还有k个插座能够将后一种插座变成前一种的。

那么图还是很容易建的。源点S=0,将n个插座连起来,汇点T=m+n+1,将m个用电器连起来,n个插座连起来,m个用电器连起来,将能够变来变去的k个插座也连起来(变之前的脸上变之后的),跑一遍模板,将m-最大流输出。(因为要求输出有几个用电器插不上电)

这道题麻烦的地方就是如何将这些字符串变成点。其实也不难,就把每个字符串记录下来,一一对应它的标号id,就使这些字符串变成数字标记了。

代码如下:

#include<cstdio>
#include<iostream>
#include<string.h>
using namespace std;
const int INF= 0x3f3f3f3f;
/**oo 表示无穷大*/
const int mm=200004;
/**mm 表示边的最大数量,记住要是原图的两倍,在加边的时候都是双向的*/
const int mn=10001;
/**mn 表示点的最大数量*/
int node,src,dest,edge;
/**node 表示节点数,src 表示源点,dest 表示汇点,edge 统计边数*/
int ver[mm],flow[mm],next[mm];
/**ver 边指向的节点,flow 边的容量,next 链表的下一条边*/
int head[mn],work[mn],dis[mn],q[mn];
/**head 节点的链表头,work 用于算法中的临时链表头,dis 计算距离*/
char ss[3000][30];//这个数组把所有字符串都记录下来
int id;//每个字符串的标记

int findid(char *str)//把每个用电器或者插座的标号记录下来
{
int i;
if(id==0)
{
strcpy(ss[1],str);
id=1;
return  1;
}
for(i=1;i<=id;i++)
if(strcmp(ss[i],str)==0)
return i;
id++;
strcpy(ss[id],str);
return id;
}
/**初始化链表及图的信息*/
void prepare(int _node,int _src,int _dest)
{
node=_node,src=_src,dest=_dest;
//for(int i=0; i<node; ++i)head[i]=-1;
//edge=0;
}
/**增加一条u 到v 容量为c 的边*/
void addedge(int u,int v,int c)
{
ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}
/**广搜计算出每个点与源点的最短距离,如果不能到达汇点说明算法结束*/
bool Dinic_bfs()
{
int i,u,v,l,r=0;
for(i=0; i<node; ++i)dis[i]=-1;
dis[q[r++]=src]=0;
for(l=0; l<r; ++l)
for(i=head[u=q[l]]; i>=0; i=next[i])
if(flow[i]&&dis[v=ver[i]]<0)
{
/**这条边必须有剩余容量*/
dis[q[r++]=v]=dis[u]+1;
if(v==dest)return 1;
}
return 0;
}
/**寻找可行流的增广路算法,按节点的距离来找,加快速度*/
int Dinic_dfs(int u,int exp)
{
if(u==dest)return exp;
/**work 是临时链表头,这里用i 引用它,这样寻找过的边不再寻找*/
for(int &i=work[u],v,tmp; i>=0; i=next[i])
if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
{
flow[i]-=tmp;
flow[i^1]+=tmp;
/**正反向边容量改变*/
return tmp;
}
return 0;
}
int Dinic_flow()
{
int i,ret=0,delta;
while(Dinic_bfs())
{
for(i=0; i<node; ++i)work[i]=head[i];
while(delta=Dinic_dfs(src,INF))ret+=delta;
}
return ret;
}

int main()
{
int n,m,k;
int u,v;
int S,T;
char s1[30],s2[30];
while(~scanf("%d",&n))
{
S=0;
id=0;
memset(head,-1,sizeof(head));
edge=0;
for(int i=1; i<=n; i++)
{
scanf("%s",s1);
u=findid(s1);
addedge(S,u,1);//源点与插座建边
}
scanf("%d",&m);
T=n+m+1;
for(int i=1; i<=m; i++)
{
scanf("%s %s",s1,s2);
v=findid(s1);
u=findid(s2);
addedge(u,v,1);//插座与电器建边
addedge(v,T,1);//电器与汇点建边
}
scanf("%d",&k);
for(int i=1; i<=k; i++)
{
scanf("%s %s",s1,s2);
u=findid(s2);
v=findid(s1);
addedge(u,v,INF);//插座之间建边,流量为INF
}
prepare(id+2,S,T);//结点总数是所有标号的用电器或插座+源汇点
printf("%d\n",m-Dinic_flow());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: