您的位置:首页 > 其它

HDU-1217 Arbitrage (有向图最大环[Floyd])

2016-04-15 17:00 393 查看


Arbitrage

http://acm.hdu.edu.cn/showproblem.php?pid=1217

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)



Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0


Sample Output

Case 1: Yes
Case 2: No


题目大意:给定n中货币,再给出m种关系表示货币a对货币b的汇率,求货币1经过兑换后是否比原本的货币1多。

大致思路:本题是看的hdu最小环的题目推荐的,所以很容易就像到了最小环的求法,不过本题是有向图,而且求最大环,将加法换成乘法,floyd不变即可,因为有向图的环可以由2个点构成,复杂度为:O(n^2),又本题只求货币1为起点的最小环,所以可以用SPFA更快的求得结果

不过感觉有点奇怪,在floyd前赋rate[1][1]=1就会WA,这个应该不影响最终结果吧,已经排除了存在自环(1,1)这种可能,实在想不到还有什么不符合的

#include <iostream>
#include <cstring>
#include <string>
#include <map>
#include <algorithm>

using namespace std;

int n,m;
double rate[35][35];
map<string,int> mp;

void floyd() {
for(int k=1;k<=n;++k)
for(int i=1;i<=n;++i)
for(int j=1;j<=n;++j)
rate[i][j]=max(rate[i][j],rate[i][k]*rate[k][j]);//更新货币i到货币j的最大汇率
}

int main() {
int kase=0;
double rat;
string curr,nxt;
while(cin>>n,n!=0) {
for(int i=1;i<=n;++i) {
cin>>curr;
mp[curr]=i;
}
memset(rate,0,sizeof(rate));
cin>>m;
while(m-->0) {
cin>>curr>>rat>>nxt;
rate[mp[curr]][mp[nxt]]=rat;
}
floyd();
cout<<"Case "<<++kase<<": ";
if(rate[1][1]-1.0>0.000001)
cout<<"Yes\n";
else
cout<<"No\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: