您的位置:首页 > 其它

Uva 10935 Throwing cards away I

2016-04-14 21:04 447 查看
Throwing cards away I

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Description

Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at thebottom. The following operation is performed aslong as there are at least two cards in the deck:Throw away
the top card and movethe card that is now on the top of thedeck to the bottom of the deck.Your task is to find the sequence of discardedcards and the last, remaining card.
Input
Each line of input (except the last) contains anumber n ≤ 50. The last line contains ‘0’ andthis line should not be processed.
Output
For each number from the input produce twolines of output. The first line presents the sequenceof discarded cards, the second line reportsthe last remaining card. No line will haveleading or trailing
spaces. See the sample for theexpected format.
Sample Input
7
1
9
10
6
0
Sample Output
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4

比较简单的队列模拟题;
直接模拟即可;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
using namespace std;
queue<int> q;
int main()
{
int n;
int temp;
while(scanf("%d",&n)!=EOF&&n)
{
if(n==1)
{
printf("Discarded cards:\n");
printf("Remaining card: 1\n");
continue;
}
for(int i=1;i<=n;++i)
{
q.push(i);
}
printf("Discarded cards: ");
while(q.size()>2)
{
temp=q.front();
q.pop();
printf("%d, ",temp);
temp=q.front();
q.pop();
q.push(temp);
}
temp=q.front();
q.pop();
printf("%d\n",temp);
temp=q.front();
q.pop();
printf("Remaining card: %d\n",temp);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: