您的位置:首页 > 其它

HDU_1556_线段树区间更新

2016-04-14 20:03 363 查看

Color the ball

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15157 Accepted Submission(s): 7544


[align=left]Problem Description[/align]
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

[align=left]Input[/align]
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

[align=left]Output[/align]
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

[align=left]Sample Input[/align]

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

[align=left]Sample Output[/align]

1 1 1
3 2 1

基础线段树区间更新。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
#define maxn 100005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
struct Node
{
int add,sum;
int l,r;
} tree[maxn<<2];

void buildTree(int l,int r,int rt)
{
tree[rt].l=l;
tree[rt].r=r;
tree[rt].add=0;
tree[rt].sum=0;
if(l==r)
{
return;
}
int m=(l+r)/2;
buildTree(lson);
buildTree(rson);
}

void pushDown(int rt)
{
if(tree[rt].add)
{
tree[rt<<1].add+=tree[rt].add;
tree[rt<<1|1].add+=tree[rt].add;
tree[rt].add=0;                 //第一次交代码时wa,没注意到pushdown过后要将根节点的lazy标记归零
}
}

void update(int L,int R,int l,int r,int rt)
{
if(L==l&&r==R)
{
tree[rt].add++;
return;
}
pushDown(rt);
int m=(l+r)/2;
if(R<=m)
update(L,R,lson);
else if(L>m)
update(L,R,rson);
else
{
update(L,m,lson);
update(m+1,R,rson);
}
}

int n;
void query(int rt)
{
if(tree[rt].l==tree[rt].r)
{
printf("%d",tree[rt].add);
if(tree[rt].l==n)
printf("\n");
else
printf(" ");
return;
}
pushDown(rt);
query(rt<<1);
query(rt<<1|1);
}

int main()
{
int a,b;
while(scanf("%d",&n)!=EOF&&n)
{
memset(tree,0,sizeof(tree));
buildTree(1,n,1);
for(int i=0; i<n; i++)
{
scanf("%d%d",&a,&b);
update(a,b,1,n,1);
}
query(1);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: