您的位置:首页 > 其它

杭电1027Ignatius and the Princess II模拟

2016-04-14 19:53 281 查看

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1027

题目:

Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?  

 

Input The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.  

 

Output For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.  

 

Sample Input 6 4 11 8  

 

Sample Output 1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10   思路:   通过观察可以发现,n个数有n!种排法;   所以可以先列出1-9内的阶乘,然后求出要改变多少个数的位置;   举个例子: 9 21   t=21-1;(因为从小大大排列是最小的顺序,)   t/3!=3 ,不等于0,所以要改变最后3+1个数字(6 7 8 9), 推出选第3+1个数字选9;剩下(6 7 8)   令t=t%3;   t/2=1;推出选第1+1个数字7;剩下(6 8);       t=t%2;   t/1=0;推出选第1+0个数字6;剩下( 8);       t=t%2;   t/1=0;推出选第1+0个数字6;无剩下数字;   结束;   另外注意下输出格式,第一次交的时候就是PE了。。。。。    
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <vector>

#define PI acos((double)-1)
#define E exp(double(1))
using namespace std;
int j[10];
int num[1000];
void so(int n,int m)
{
int change=9,point,all=n;
memset(num,0,sizeof(num));
while(m/j[change]==0)
change--;
point = n-change;
all=change +1;
for(int i =point; i<=n; i++)
num[i]=1;
printf("%d",1);
for(int i =2; i<point; i++)
printf(" %d",i);
while(all--)
{
int t=m/j[change];
for(int i =point,k=0; i<=n; i++)
if(num[i])
{
if(k==t)
{
printf(" %d",i);
num[i]=0;
break;
}
k++;
}
m%=j[change--];
}
putchar('\n');
}
int main(void)
{
int n, m;
j[0]=j[1] = 1;
for (int i = 2; i <= 9; i++)
j[i] = j[i - 1] * i;
while (scanf("%d%d", &n, &m) == 2)
{
if(m == 1)
{
for(int i=1; i<=n-1; i++)
printf("%d ",i);
printf("%d\n",n);
}
else
so(n,m-1);
}

return 0;
}
View Code

 

  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: