您的位置:首页 > 其它

HDU 1013 Digital Roots(模拟计算)

2016-04-14 17:01 246 查看

Digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 67073 Accepted Submission(s): 20950



[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or
more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

[align=left]Output[/align]
For each integer in the input, output its digital root on a separate line of the output.

[align=left]Sample Input[/align]

24
39
0


[align=left]Sample Output[/align]

6
3


[align=left]AC代码:[/align]

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
char a[1010]; //数组要开大一些,写成100就会WA
while(cin>>a){
int len=strlen(a);
if(len==1&&a[0]=='0')break;
int sum=0;
for(int i=0;i<len;i++){
sum+=a[i]-'0';
}
sum%=9;
if(sum==0)sum=9;
printf("%d\n",sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: