您的位置:首页 > 其它

hdu 1078 FatMouse and Cheese(记忆化搜索)

2016-04-12 17:59 323 查看


FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7569    Accepted Submission(s): 3129


Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 

The input ends with a pair of -1's. 

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

 

Sample Output

37

 

Source

Zhejiang University Training Contest 2001

 

Recommend

We have carefully selected several similar problems for you:  1080 1074 1024 1081 1025 

 

Statistic | Submit | Discuss | Note

普通搜索 会超时的  感觉这道题和滑雪(poj1088,nyoj10)一样  只不过多了一些方向  

首先附上超时代码 +理解错误(He eats up the cheese where he stands and then runs either horizontally or vertically to another location.)

#include <stdio.h>
#include <string.h>
int n,k;
int map[105][105];
bool vis[105][105];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int max;
bool limit(int x1,int y1,int x,int y)
{
if(vis[x1][y1]||x1<0||y1<0||x1>=n||y1>=n||map[x1][y1]<=map[x][y])
return false;
return true;
}
void dfs(int x,int y,int sum)
{
if(sum>max)
max=sum;
for(int i=0;i<k;i++)
{
for(int j=0;j<4;j++)
{
int x1=x+dir[j][0];
int y1=y+dir[j][1];
if(limit(x1,y1,x,y))
{
vis[x1][y1]=true;
sum+=map[x1][y1];
dfs(x1,y1,sum);
vis[x1][y1]=false;
sum-=map[x1][y1];
}
}
}
}
int main()
{
while(~scanf("%d %d",&n,&k))
{
if(n==-1&&k==-1)
break;
memset(map,0,sizeof(map));
memset(vis,false,sizeof(vis));
if(k>n+n)
k=n+n;
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
scanf("%d",&map[i][j]);
max=0;
vis[0][0]=true;
dfs(0,0,map[0][0]);
printf("%d\n",max);
}
return 0;
}理解为可以任意走k步了  Wa也是应该的

记忆化搜索:

#include <stdio.h>
#include <string.h>
#include <queue>
#include <math.h>
using namespace std;
int n,k,result;
int map[105][105];
int dp[105][105];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
struct node
{
int x,y;
};
bool limit(int x1,int y1,int x,int y)
{
if(x1<0||y1<0||x1>=n||y1>=n||map[x1][y1]<=map[x][y])
return false;
return true;
}
int dfs(int x,int y)
{
if(dp[x][y])
return dp[x][y];
for(int i=1;i<=k;i++)
{
for(int j=0;j<4;j++)
{

int x1=x+dir[j][0]*i;
int y1=y+dir[j][1]*i;
if(limit(x1,y1,x,y))
{
int z=dfs(x1,y1);
if(dp[x][y]<z+map[x1][y1])
dp[x][y]=z+map[x1][y1];
}
}
}
return dp[x][y];
}
int main()
{
while(~scanf("%d %d",&n,&k))
{
if(n==-1&&k==-1)
break;
result=0;
memset(map,0,sizeof(map));
memset(dp,0,sizeof(dp));
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
scanf("%d",&map[i][j]);
printf("%d\n",dfs(0,0)+map[0][0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: